Cd 200 vervormd geluid en traag tempo muziek.

Digitale schijfjes en analoge MFB boxen gaan ontzettend goed samen... Alles over CD spelers, DAC's en loopwerken hier!

Moderator: Moderators

Gebruikersavatar
bramjacobse
Berichten: 1325
Lid geworden op: 22 aug 2014, 09:02
Locatie: Almere-Haven
Contacteer:

25 mar 2019, 19:06

Draait de CD net te langzaam "MCES" volgen ...
MGf
Berichten: 563
Lid geworden op: 24 jan 2016, 10:33
Locatie: Regio Arnhem
Contacteer:

25 mar 2019, 20:52

Will schreef:
25 mar 2019, 18:57
Nou, het circuit maakt toch wel gebruik van een kristal referentie, nl xtal 1654
Nee, dat is een 4,2336 MHz xtal. Die wordt gebruikt om de 44.1KHz op te wekken.
Met 4.2336 kan je volgens mij geen 8,64MHz maken.
Hoe ik het schema interpreteer, is dat de 8,64MHz in "fase" wordt gestuurd middels de 44.1kHz.
Dit is volgens mij geen gewone PLL/VCO combinatie.
Will schreef:
25 mar 2019, 18:57
Het is een PLL met VCO dus die stabiliseert zichzelf. De temperatuurafhankelijkheid is geen probleem.
Dat zou ik ook verwachten, maar dat doet ie dus niet. :think: :shock:
Will schreef:
25 mar 2019, 18:57
Alleen haal je nu de bedoelde frequentie niet. Kan aan C2695 liggen, of de VCO spanning op pen 13 van de VCO. Maar ook idd aan de transistoren of aan de fasevergelijker (pll).
C2695 heb ik vervangen. De spanning op pen 13 is lager dan in het schema wordt aangegeven. Het PLL IC is ook vervangen.
Will schreef:
25 mar 2019, 18:57
Je schrijft dat je circuit niet goed begrijpt. Ken je wel de werking van een PLL/VCO combinatie?
In de basis ken ik die wel, maar niet voldoende om het schema te begrijpen in combinatie met de datasheets van de gebruikte IC's.
bramjacobse schreef:
25 mar 2019, 19:06
Draait de CD net te langzaam "MCES" volgen ...
MCES stuurt de spindle stabiel, maar op een te lage bitrate aan. Dus de terugkoppeling gaat goed, maar de referentie van hoe de MCES wordt aangestuurd/bijgestuurd is onjuist.
De 8,64 MHz is te laag al bij het aanzetten van de cd-speler, dus nog voordat MCES de spindle motor aanstuurt om de juiste bitrate te halen.
~ Mark ~
Soldeerbout, schroevendraaiers en een hamer.
Gebruikersavatar
Will
Berichten: 3751
Lid geworden op: 24 mei 2009, 21:56
Locatie: Het uiterste Zuiden
Contacteer:

25 mar 2019, 21:43

MGf schreef:
25 mar 2019, 20:52
Will schreef:
25 mar 2019, 18:57
Nou, het circuit maakt toch wel gebruik van een kristal referentie, nl xtal 1654
Nee, dat is een 4,2336 MHz xtal. Die wordt gebruikt om de 44.1KHz op te wekken.
Met 4.2336 kan je volgens mij geen 8,64MHz maken.
Hoe ik het schema interpreteer, is dat de 8,64MHz in "fase" wordt gestuurd middels de 44.1kHz.
Dit is volgens mij geen gewone PLL/VCO combinatie.
In een PLL zit ook een deler. De factor kan elk denkbaar geheel getal zijn. De deler zit volgens voor zover ik kan zien in IC6805 (de sophi print?)
Het signaal van de kristal-generator gaat als clock naar 6661, en naar de PLL, ook na deling 6661 in waarbij RFCK ook mee doet. In de PLL wordt dit vergeleken met LRCK.
MGf schreef:
25 mar 2019, 20:52
Will schreef:
25 mar 2019, 18:57
Alleen haal je nu de bedoelde frequentie niet. Kan aan C2695 liggen, of de VCO spanning op pen 13 van de VCO. Maar ook idd aan de transistoren of aan de fasevergelijker (pll).
C2695 heb ik vervangen. De spanning op pen 13 is lager dan in het schema wordt aangegeven. Het PLL IC is ook vervangen.
Heb je de C ook al eens vervangen door een kleinere waarde?

Dat de VCO spanning te laag is is waarschijnlijk de oorzaak van de te lage frequentie. Heb je wel ongeveer 1,6V op de basis van de transistor?
Je kan wat pielen met R3711. Als je die wat kleiner maakt kun je kijken hoe de schakeling reageert.
Een verzamelaar ziet niet wat hij al heeft, hij ziet alleen wat hij nog mist.
MGf
Berichten: 563
Lid geworden op: 24 jan 2016, 10:33
Locatie: Regio Arnhem
Contacteer:

25 mar 2019, 22:24

Will schreef:
25 mar 2019, 21:43
In een PLL zit ook een deler. De factor kan elk denkbaar geheel getal zijn. De deler zit volgens voor zover ik kan zien in IC6805 (de sophi print?)
Het signaal van de kristal-generator gaat als clock naar 6661, en naar de PLL, ook na deling 6661 in waarbij RFCK ook mee doet. In de PLL wordt dit vergeleken met LRCK.
Dank voor de tips!
Ik ben nog even verder gedoken in de 6661, een Sony CX7934. XTAL is de input voor de clock. LRCK komt uit het Timing & Control Signal Generator deel van dat IC. Van 8,64MHz is onmogelijk 44,1kHz te maken, dat is niet deelbaar met een geheel getal.
Dus ergens moet die PLL lock op een andere manier tot stand komen.
Die LRCK is vermoedelijk wel het signaal om de PLL z'n werk te laten doen. Dus die ga ik eens op de scope/data logger bekijken en vergelijken met de signalen uit de datasheet. Dit zou het Links/Rechts signaal moeten zijn.
Will schreef:
25 mar 2019, 21:43
Heb je de C ook al eens vervangen door een kleinere waarde?

Dat de VCO spanning te laag is is waarschijnlijk de oorzaak van de te lage frequentie. Heb je wel ongeveer 1,6V op de basis van de transistor?
Je kan wat pielen met R3711. Als je die wat kleiner maakt kun je kijken hoe de schakeling reageert.
Ik zal die C ook eens verkleinen. die 1,6v haalt ie niet op de basis van de transistor. Hoeveel precies, weet ik niet meer.
Ik heb al wel met de weerstanden zitten pielen (iets parallel er overheen gezet). Daarmee verandert de frequentie wel, dus dat werkt wel, in zekere zin. :)
~ Mark ~
Soldeerbout, schroevendraaiers en een hamer.
Gebruikersavatar
bramjacobse
Berichten: 1325
Lid geworden op: 22 aug 2014, 09:02
Locatie: Almere-Haven
Contacteer:

14 apr 2019, 14:59

En draait ie al op het juiste snelheid...?!

Gr Bram
MGf
Berichten: 563
Lid geworden op: 24 jan 2016, 10:33
Locatie: Regio Arnhem
Contacteer:

14 apr 2019, 16:15

Alsof dat je meekijkt in mijn hobbyhok, Bram... ;)

Hij draait nu, sinds vanmiddag, op de juiste snelheid met een print van een CD202 (met de MAB8410 overgezet uit de CD200, ivm de software versie).
Met die print is de frequentie stabiel, ook niet gevoelig voor temperatuur schommelingen.
Daarvoor nog het Sony board uitgewisseld, maar daar zit niet het probleem in.
Mijn conclusie is dat de oscillator vrij loopt en niet in een PLL lock komt. Ondanks dat ik het PLL IC en oscillator IC heb vervangen uit een speler die dit probleem niet hadden. Dus nu eens verder kijken naar de bron voor de PLL lock en of er misschien gewoon ergens een printbreuk zit ofzo. :think:
Is vast ook hier weer iets kleins :mrgreen:
~ Mark ~
Soldeerbout, schroevendraaiers en een hamer.
Gebruikersavatar
bramjacobse
Berichten: 1325
Lid geworden op: 22 aug 2014, 09:02
Locatie: Almere-Haven
Contacteer:

14 apr 2019, 16:28

MGf schreef:
14 apr 2019, 16:15
Is vast ook hier weer iets kleins :mrgreen:
Denk ik ook :mrgreen: , is het niet de SAA7010..? pin 26 ( bit clock )
MGf
Berichten: 563
Lid geworden op: 24 jan 2016, 10:33
Locatie: Regio Arnhem
Contacteer:

14 apr 2019, 19:05

Vind ik eigelijk niet logisch, maar om nou elke keer componenten te swappen, dat vind ik niet echt repareren. Maar voor nu denk ik de beste optie. :)
/CLDE vormt de bron voor de PLL die MCES stuurt om de bitstream constant te houden. Die is wel constant, maar de bitrate te laag.
Dus dat PLL circuit lijkt me goed, maar een verkeerde referentie.
Maar misschien maak ik een denkfout. :o :think:
Die SAA's worden allemaal nogal warm, dus zou eigenlijk best kunnen dat er een gesneuveld is en raar gaat doen. Dat ken ik van de SAA7030 in de Revox.
~ Mark ~
Soldeerbout, schroevendraaiers en een hamer.
Gebruikersavatar
bramjacobse
Berichten: 1325
Lid geworden op: 22 aug 2014, 09:02
Locatie: Almere-Haven
Contacteer:

14 apr 2019, 19:22

MGf schreef:
14 apr 2019, 19:05
Maar om nou elke keer componenten te swappen, dat vind ik niet echt repareren.
Een hele print swappen wel...? :?

Maar in z'n saa7010 zitten aardig wat timing dingen

Afbeelding
MGf
Berichten: 563
Lid geworden op: 24 jan 2016, 10:33
Locatie: Regio Arnhem
Contacteer:

14 apr 2019, 21:18

bramjacobse schreef:
14 apr 2019, 19:22
Een hele print swappen wel...? :?
Nee, zeker niet. Dat is ook niet de oplossing want ik wil die print gewoon in de cd202 blijven gebruiken. Was meer een makkelijke weg om een aantal dingen uit te sluiten.
Een stuk makkelijker dan onderdelen van een andere print uit te solderen en in deze print zetten.
bramjacobse schreef:
14 apr 2019, 19:22
Maar in z'n saa7010 zitten aardig wat timing dingen
Die swap toch maar geprobeerd, maar helaas.
Ben nu alle digitale signalen aan het bekijken/vergelijken met het service manual.
De twee divider IC’s lijken te doen wat ze moeten doen. Die maken netjes van de 4.2336 MHz de 44.kHz, etc.
Nu de rest nog. :D
~ Mark ~
Soldeerbout, schroevendraaiers en een hamer.
Gebruikersavatar
bramjacobse
Berichten: 1325
Lid geworden op: 22 aug 2014, 09:02
Locatie: Almere-Haven
Contacteer:

15 apr 2019, 17:39

Advies in service manual "Trail and Error" :shhh:


Afbeelding
MGf
Berichten: 563
Lid geworden op: 24 jan 2016, 10:33
Locatie: Regio Arnhem
Contacteer:

15 apr 2019, 21:22

Ja, dat stukje had ik ook al gelezen.... het is niet anders.
Dat ga ik dan toch maar doen.
~ Mark ~
Soldeerbout, schroevendraaiers en een hamer.
MGf
Berichten: 563
Lid geworden op: 24 jan 2016, 10:33
Locatie: Regio Arnhem
Contacteer:

18 mei 2019, 19:26

Ik heb de hoop opgegeven en de werkende print uit een CD202 overgezet (MAB's uitgewisseld).
Hand vol IC's en andere twijfelachtige componenten vervangen, maar hij bleef instabiel en te langzaam afspelen.
Misschien ga ik nog eens met die andere print aan de gang, maar het koste me gewoon te veel tijd en had er geen zin meer in.

Maar goed, Niels krijgt wel weer een werkende cd-speler terug. :-)
~ Mark ~
Soldeerbout, schroevendraaiers en een hamer.
Gebruikersavatar
Fotohuis
Berichten: 6529
Lid geworden op: 19 feb 2016, 17:37
Locatie: R'stein soms Mykolaiv
Contacteer:

18 mei 2019, 20:37

Ja, digitale techniek: (Soms om gek van te worden!)
http://www.svema.info
Dynavox TPR-3 6N3P-EV voorversterker, ET-100+Teufel U.20, Theater 500. N4504, N4511, N4450, N2521, N2507, (1)408, 212, 312, 222, draaitafels +GP401/412 Mk2 Sh./MC-3. CD204, CDF200. NAD C352, C422, C521BEE+FB820. 22RH743+22RH544/79R
Gebruikersavatar
bramjacobse
Berichten: 1325
Lid geworden op: 22 aug 2014, 09:02
Locatie: Almere-Haven
Contacteer:

11 jul 2019, 15:42

Ik heb ook ruzie met een CD200 die af en toe begint te pruttelen op Links en Rechts.
Na uren spelen ineens vervormt geluid. Ik denk dat ik de oorzaak gevonden heb.
Corrosie op een VCO-ic...op en mogelijk ook tussen de pootjes. 74ls264

Afbeelding

Het ic maakt de klok voor het sophie-printje

Afbeelding


Afbeelding
Plaats reactie